Card payment issues with Nets

Incident Report for Mondido

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 16:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2026 - 13:43 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 13, 2026 - 08:00 UTC

Update

We're still working on a solution and sincerely apologise for the issues this might have on your business
Posted Mar 12, 2026 - 21:08 UTC

Identified

We're still working on a solution and sincerely apologise for the issues this might have on your business
Posted Mar 12, 2026 - 12:00 UTC

Investigating

We are currently investigating this issue.
Posted Mar 11, 2026 - 10:45 UTC

Identified

We're currently experiencing a major outage with card payments using the Nets acquiring service.
Posted Mar 11, 2026 - 10:45 UTC
This incident affected: Payment Gateway and Payment Methods (Card).